Wii Games Do Not Work on RVLoader

Joined
May 11, 2021
Messages
24
Likes
13
Location
Somewhere on this Earth...
Portables
e^(i x π) + 0!
Hello all, sorry if this is a bit of a noob question, but I have a Wii that has been modded with RVLoader. It currently uses an SD to USB adapter. All GameCube games work on it just fine, but any Wii games will not work. I press the A button and then nothing happens. Is there anything that I'm missing? Thanks for any advice you can give
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
.
Joined
Feb 5, 2017
Messages
3,934
Likes
3,099
Location
Banana Bender Land, Australia
Portables
6
What video output are you using?
 
Joined
May 11, 2021
Messages
24
Likes
13
Location
Somewhere on this Earth...
Portables
e^(i x π) + 0!
I am using a Wii2HDMI adapter with an HDMI cord. No Component Cables. Although, I haven't tried it with the Component Cables yet
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
.
Joined
Feb 5, 2017
Messages
3,934
Likes
3,099
Location
Banana Bender Land, Australia
Portables
6
Try tapping A for 10 seconds after loading a Wii game. Might be defaulting to 480i on launch
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
.
Joined
Feb 5, 2017
Messages
3,934
Likes
3,099
Location
Banana Bender Land, Australia
Portables
6
I am interested in both this problem and why this might help.
Sometimes even when 480p is forced, the game will start in 480i. So when it loads the menu that asks if you want to display in 480i or 480p, if your screen doesn't support 480i it'll go black or display no signal. The default selected option in that menu is 480p, so mashing A will select 480p as the desired display mode and the screen should then be able to display correctly.
 
Joined
Jun 21, 2016
Messages
350
Likes
493
Location
Northern New Jersey
Sometimes even when 480p is forced, the game will start in 480i. So when it loads the menu that asks if you want to display in 480i or 480p, if your screen doesn't support 480i it'll go black or display no signal. The default selected option in that menu is 480p, so mashing A will select 480p as the desired display mode and the screen should then be able to display correctly.
Interesting. Thanks!
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
.
Joined
Feb 5, 2017
Messages
3,934
Likes
3,099
Location
Banana Bender Land, Australia
Portables
6
A very long time after this discussion happened, you've helped another modder out.
Cheers Stitches!
No worries. Another thing that has helped people with the same issue is to switch to using NTSC copies of problem games. Seems some PAL titles are super jank in how they handle video
 
Joined
Nov 13, 2022
Messages
192
Likes
71
It might be a bit too late to help TheAnimeFan out, but I remember reading in the Wii Trimming and Troubleshooting Guide that Wii games will not load through SD period. TheAnimeFan mentioned using a USB to SD converted. Could that be the culprit (not that their necessarily still trying to fix it a year and a half later)?
 
Top