Worklog Yet, another portable Wii

Joined
Apr 2, 2022
Messages
20
Likes
22
Location
The Blue Marble
Portables
1/8
You've made a pretty interesting model! But I'd recommend putting the PMS-lite juuust underneath the PMS-PD; wiring will be shorter and will be more convenient :). If you do so, make sure the screwposts (if you will have them) are facing the right way round for wiring the aforementioned PCBs together.

And, as a question, you say you are using a DIY heatsink. Why is this? (I don't mean to say that in a criticizing way, only wondering.)
 
Last edited:

Shipyu

.
Joined
Aug 13, 2022
Messages
56
Likes
29
You've made a pretty interesting model! But I'd recommend putting the PMS-lite juuust underneath the PMS-PD; wiring will be shorter and will be more convenient :). If you do so, make sure the screwposts (if you will have them) are facing the right way round for wiring the aforementioned PCBs together.

And, as a question, you say you are using a DIY heatsink. Why is this? (I don't mean to say that in a criticizing way, only wondering.)
I'm really happy you find my project interesting :)
I've done a LOT of 3D modeling and tinkering. I've totally finished :
  1. cooling system with heatsink, copper plate, fan and motherboard are all held in place well and tightly
  2. the battery holder in which i'll glue the 2 metallic parts, the flat one and the springy one. It'll allow me to remove the cells if i need to, no glue or solder used.
  3. the PMS, PD are held in place with screws in the bottom part
  4. MX chip and BT module are held in place by snapping them in a precise-made design that holds them very thightly without the need of using glue or screws
  5. the GC 2+ will be attached on the upper case with screws so i dont have to put a ton of wires from top to bottom parts.
  6. I'm designing the controller parts, I'll do 2 joysticks, 4 ABXY buttons, and a 4-button cross (allows you to do 2 directions at the same time...). For the shoulder buttons I'll do dual sensitivity using multiple buttons and I'll try to make sure we can press anywhere on the button for it to be in a pressed state.
  7. I still need to find a way to attach the screen very weel + its board.
My aime is to glue nothing and make every board or part removable as easily as possible + making the capable management as clean as possible.
Here are some screenshots...
1.png
Assemblage v43.png
inside.png
2.png
 

Shipyu

.
Joined
Aug 13, 2022
Messages
56
Likes
29
So I've received all the PCBs and stuff needed to make the portable Wii! Finally!
I just have to finalize the 3D model and start printing at least the bottom part.
Though, I have a BIG issue with my display... It's aweful. Colors are wrong, too much red or not enough green/blue. There are some strange shapes when the color changes on the display but I have no idea where that can come from, how to solve it or if the display is just bad...
Video played on my PC, display used HDMI.
I hope someone will find out what's wrong with it! :)
 

Shipyu

.
Joined
Aug 13, 2022
Messages
56
Likes
29
When I first plugged the screen in its driver board, I put it the other way by mistake because there was no clear indication on the way it should have been put. After checking one picture on the product on Aliexpress, I figured out I didn't plug it well and that's why it didn't turn on.
After plugging it in the other way, it turned on.
So my question is, could some damages have been done with my wrong manipulation? If so, is the driver board damaged or is it the LCD display?
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
Joined
Feb 5, 2017
Messages
2,741
Likes
2,096
Location
Banana Bender Land, Australia
Portables
6
When I first plugged the screen in its driver board, I put it the other way by mistake because there was no clear indication on the way it should have been put. After checking one picture on the product on Aliexpress, I figured out I didn't plug it well and that's why it didn't turn on.
After plugging it in the other way, it turned on.
So my question is, could some damages have been done with my wrong manipulation? If so, is the driver board damaged or is it the LCD display?
It's possible that either or both were damaged to a degree
 

Shipyu

.
Joined
Aug 13, 2022
Messages
56
Likes
29
It's possible that either or both were damaged to a degree
I'll buy another one either very soon so I get it a few days or when I'll have the wii finished
I'd like to buy the same one but is there a way to know if the screen was that bad in the beginning or not?
There is only 2 orders of this screen on Aliexpress but the seller looks legit and sells a lot of other screens
Could a display even be that bad without being damaged?
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
Joined
Feb 5, 2017
Messages
2,741
Likes
2,096
Location
Banana Bender Land, Australia
Portables
6
I'll buy another one either very soon so I get it a few days or when I'll have the wii finished
I'd like to buy the same one but is there a way to know if the screen was that bad in the beginning or not?
There is only 2 orders of this screen on Aliexpress but the seller looks legit and sells a lot of other screens
Could a display even be that bad without being damaged?
It's possible that the unit was DOA, but sadly it's not possible to determine that now. I also wouldn't worry too much about the sales numbers of that listing, they close and re-open all the time
 

Shipyu

.
Joined
Aug 13, 2022
Messages
56
Likes
29
Is it right to have ~38 ohms between R, G, B and GROUND for each color?
I just finished soldering ten 0.3mm magnet wires to the display board and the motherboard/video IC : R; Ground, G, Ground, B, Ground, H, Ground, V,Ground. I twisted each data wire with a ground. Hope it's gonna be good
I'll very soon know if all the trim and solders were right !!
 
Last edited:

Shipyu

.
Joined
Aug 13, 2022
Messages
56
Likes
29
Just tested it. Fan spins for a second and turns off. There is a very high pich noise while its turned on.
it seems that there is a short between 3.3 and 1.8V. What did go wrong..?
 

Shipyu

.
Joined
Aug 13, 2022
Messages
56
Likes
29
Just tested it. Fan spins for a second and turns off. There is a very high pich noise while its turned on.
it seems that there is a short between 3.3 and 1.8V. What did go wrong..?
There was a tiny, tiny, tinyyy solder blob on one of the video IC... I hope its not dead
 

Shipyu

.
Joined
Aug 13, 2022
Messages
56
Likes
29
Oh man, sounds like your having some issues. Could I see a picture of the PMS-lite?
20220901_150747.jpg

It is still working because when disconnected from the wii it gives the correct voltages. It doesnt work when only 3.3v is soldered to the wii. I'm trying with only 1v and 1.15.
EDIT : It's working with both voltage.
I know it works because the fan stays on :)
EDIT : I think I'll to buy a new wii tbh. When i solder 3.3v to the LDO, it the pms lite doesnt turn on att all anymore. I have no clue why or how that happens
 

Shipyu

.
Joined
Aug 13, 2022
Messages
56
Likes
29
Could I also see the wii? (Sorry I didn't ask this initially)
20220901_152251.jpg20220901_152301.jpg
As it is, the fan will work when i push the button and the voltages are correct. As soon as i touch the LDO with 3.3v, everything dies instantly
It feels like its some kind of protection on the pms lite side
I'd need to know if i have to buy a new wii. I could get one today for 20e
 

Shipyu

.
Joined
Aug 13, 2022
Messages
56
Likes
29
After my stupid mistakes of yesterday, I came to the conclusion I fried the wii.
So I've bought a new one and I'll testé everything I can before trimming it!
Starting with the VGA video to my display. I think I wired everything correctly to the driver board but I'm getting no video when I select VGA as video input
Though, I'm not getting a "no signal" message.
What could have I done wrong?
20220902_104547.jpg
 

Shipyu

.
Joined
Aug 13, 2022
Messages
56
Likes
29
And I can confirm that composit video works after I removed the VGA patch and soldered the composite cable.
 

Shipyu

.
Joined
Aug 13, 2022
Messages
56
Likes
29
I've got some good news : My trimmed Wii is working !
My batteries were not charged enough and I guess with the voltage drop, because I was only using one battery, it made the PMS Lite shutdown.
I even managed to get VGA video output working :D
Now its time for the final 3D Modeling hours and I'll start printing the case
Also I couldnt get the USB to work properly after soldering D- and D+ on CM1 but I'll see that later on.
20220902_175909.jpg
 

Shipyu

.
Joined
Aug 13, 2022
Messages
56
Likes
29
I thought everything would come smoothly from now on...
I was wrong
While booting the wii with the Bluetooth, USB line and rvl Amp freshly soldered on, it was working and rvloader would boot up but then while loading the USB key, I would get a white screen.
After a few reboot, the wii wouldn't boot at all, the fan wouldn't spin
I removed everything from the box I 3d printed this morning and tested the voltages on my pms : the 5v and F+ rails were at 3.5v when the pms was shut down and it would go down to 1v when turned on...
At least the other voltages work great but that's really doesn't feel great
20220904_155914.jpg20220904_221937.jpg
 
Top