Discussion Ideas, questions, etc, Post em here!

Joined
Oct 24, 2023
Messages
5
Likes
0
Check the wiring to the sticks, if there is an issue the sticks can jump around causing some software to appear frozen or broken
Thanks for the reply! Originally I tried to use the FFC cable, but I fucked up the mounts. I left the mounts on and just used individual wires. After your reply, I tried removing the connectors to see if they were causing some issue. These photos look pretty messy still, but I just cleaned the spots with copper solder wick and then a qtip with IPA (there's a few little cotton fibers left on there). Same issue, no controls working.

I've checked each connecting wire for continuity, as well as the blobs connecting to the GC+2.0. I also went in-between each wire to make sure they weren't shorting together anywhere. Everything appears normal there.

When I was in priiloader and the controls were working, I noticed only the D-pad worked for navigation-- at the time, I assumed the left stick just wasn't usable on that menu. Is that indicative of an issue?
 

Attachments

Rararagi

.
.
Joined
Sep 18, 2022
Messages
26
Likes
41
Location
SP-BR
Thanks for the reply! Originally I tried to use the FFC cable, but I fucked up the mounts. I left the mounts on and just used individual wires. After your reply, I tried removing the connectors to see if they were causing some issue. These photos look pretty messy still, but I just cleaned the spots with copper solder wick and then a qtip with IPA (there's a few little cotton fibers left on there). Same issue, no controls working.

I've checked each connecting wire for continuity, as well as the blobs connecting to the GC+2.0. I also went in-between each wire to make sure they weren't shorting together anywhere. Everything appears normal there.

When I was in priiloader and the controls were working, I noticed only the D-pad worked for navigation-- at the time, I assumed the left stick just wasn't usable on that menu. Is that indicative of an issue?
Looks like some broken traces on photo 2. Try redo these lines.
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
.
Joined
Feb 5, 2017
Messages
3,926
Likes
3,094
Location
Banana Bender Land, Australia
Portables
6
Yeah the ripped traces might mean the through holes are no longer connected to the GC+, I can't remember if there's any redundant routing in the other side. You'll probably need to repair those traces by soldering a short wire from the GC+ pad to the respective through hole. Also IIRC priiloader doesn't support analog sticks, so face buttons only is indeed normal
 
Top