Solved RGB difficulty with Wii VGA

Joined
Jan 9, 2020
Messages
27
Likes
10
I've been having difficulties with the RGB connections for my G-Wii's VGA. As it stands, my display looks like this:
IMG_20230729_155800127.jpg

Here are the approximate resistances to GND for all 3 (both on the Wii and the screen board):
R: 37.5
G: 75
B: 75
Based on what I've read, I think that means the G and B connections both need work. Is that correct?
Here's what they look like right now:
IMG_20230729_160539768_HDR.jpg

IMG_20230729_160557984_HDR.jpg

IMG_20230729_160615261_HDR.jpg

Is there anything else I could be missing, or do I just need better solder joints on G and B (or possibly their ground lines)?
 

Attachments

Stitches

2 and a Half Dollarydoos
Staff member
.
.
.
Joined
Feb 5, 2017
Messages
3,934
Likes
3,099
Location
Banana Bender Land, Australia
Portables
6
If the wiring is correct, you probably need to adjust the colour balance on the screen. Sometimes they need some tweaking
 
Joined
Jan 9, 2020
Messages
27
Likes
10
I just went back, and the wiring was correct, but after messing with the settings enough, I think I'm satisfied with what I've got. Strangely enough, I've tried this before, but the result came out better this time, so I'm keeping it. Thanks for the tip!
IMG_20230730_204229801_HDR.jpg
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
.
Joined
Feb 5, 2017
Messages
3,934
Likes
3,099
Location
Banana Bender Land, Australia
Portables
6
Nice. I don't know why that happens sometimes, but I've had a few screens where I had to lower the colour intensity for all three channels to 50% to get it to look correct
 
Top